Open-Capture Forums Open-Capture : paramétrage Problème installation

Étiqueté : 

6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #1531
    Geoffrey
    Participant

    Bonjour j’ai installé en suivant à la lettre le tuto : https://edissyum.gitbook.io/open-capture-for-invoices-v2/francais/installation

    je l’ai choisi en mode supervisor 3 processes.

    à la fin de l’installation problème apache que je tente de résoudre mais je ne suis pas sure de ce que je fais :

    Par la suite ça à l’aire de fonctionner mais la surprise est que lorsque j’upload rien ne se passe…

    Voici en PJ mon investigation.

    Est-ce qu’une âme charitable pourrait y jetter un coup d’oeil et me venir en aide ?

     

    • Ce sujet a été modifié le il y a 1 année et 10 mois par Geoffrey.
    Attachments:
    You must be logged in to view attached files.
    #1536
    Nathan Cheval
    Modérateur

    Bonjour,

    Le problème ne vient pas du double slash je vous rassure 🙂

    C’est plus du côté de l’erreur dans les logs qu’il faut se tourner. C’est une erreur que je viens de corriger en sortant un petit tag correctif 2.3.2

    Merci de faire les commandes suivantes afin d’update votre installation :

    cd /var/www/html/opencaptureforinvoices/bin/install/
    sudo ./update.sh

    Lead Dev Open-Capture

    #1543
    Geoffrey
    Participant

    Bonjour,

    Avant tout, merci pour votre réponse.

    L’update s’est bien passé, j’ai égamement recreer la BDD. Restart tous les services et Supervisors (qui ne reboot pas seul en fin d’update, si le produit est aussi géniale que j’ai l’impression, je ferais sans doute une branche pour gérer le cas des Supervisors car il update et reboot les services que sur systemctl on dirait).

    Après quoi le téléversement de fichier fonctionne.

    Par contre impossible de visualiser l’image dans le splitter. Je pense avoir trouver le problème sans savoir comment le résoudre…

    C’est l’utilisateur dans le fichier de conf d’apache que j’ai bidouillé pour faire démarré Apache en fin d’installation.

    #WSGIDaemonProcess opencapture user=root group=www-data threads=5

    WSGIDaemonProcess opencapture user=user group=www-data threads=5

    J’ai lancé l’install avec un user frecheent créer se nomant user.

    Pour tout le monde le user root fonctionne? Je pense mettre les droits user sur le dossier temporaire des images mais n’aurais-je pas d’autre problème par la suite ?

    Merci de votre aide.

    Attachments:
    You must be logged in to view attached files.
    #1545
    Nathan Cheval
    Modérateur

    Une nouvelle version (2.4.0) est en préparation, je note de rajouter le correctif du reboot supervisor dans le script d’update 🙂

    Pour ce qui est du root, j’ai oublié de le mentionner dans la documentation d’installation mais il faut éviter de le lancer en tant que root. Je le rajoute également

     

    merci

    Lead Dev Open-Capture

    #1546
    Geoffrey
    Participant

    J’ai push le update.sh

    concernant mon problème, je n’arrive pas à le résoudre .

    J’ai effectivement upload les droits sur ce dossier en récursif aux fils /var/docservers/OpenCapture/splitter/batches/

    Par contre quel fichier crée les dossiers temporaires car dès le dépôt d’un nouveau PDF il crée un dossier temp qui ne possède pas les bons droits et je me retrouve de nouveau bloqué car non traitable sur l’interface…

     

    De plus (lorsque je force les droits sur le dossier temporaire fraichement créer ) j’ai ce message d’erreur qui apparait alors qu’il passe bien la main au verifier

     

    Attachments:
    You must be logged in to view attached files.
    #1548
    Nathan Cheval
    Modérateur

    Vous pouvez commencer par refmettre les droits du docservers comme il faut :

    sudo chmod -R 775 /var/docservers/
    sudo chown -R user:www-data /var/docservers/

     

    Ensuite, vérifier également dans le fichier /etc/supervisor/conf.d/OCForInvoices_Split-worker.conf et /etc/supervisor/conf.d/OCForInvoices-worker.conf  que l’utilisateur root n’est pas présent

     

    Pour ce qui est de l’erreur 500, pouvez-vous me donner le retour présent dans /var/log/apache2/error.log (en sudo) lorsque l’erreur se présente ?

    Lead Dev Open-Capture

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.