Open-Capture Forums Open-Capture : installation Import de la facture

7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #1112
    abdessamed
    Participant

    Bonjour,

    Je viens d’installer Open-Capture.

    L’interface est fonctionnelle. Par contre, lorsque je veux uploader une facture, j’ai une erreur juste après l’upload (upload depuis l’interface graphique.

    Lorsque je lance la commande manuellement voici la stacktrace :
    python3 /opt/OpenCaptureForInvoices/launch_worker.py -c /opt/OpenCaptureForInvoices/instance/config.ini -f /opt/OpenCaptureForInvoices/instance/upload/df17adeba756536c467356ca2532ea61.pdf
    Traceback (most recent call last):
    File “/opt/OpenCaptureForInvoices/launch_worker.py”, line 38, in <module>
    launch(args)
    File “/usr/local/lib/python3.8/dist-packages/kuyruk/task.py”, line 64, in __call__
    self.send_to_queue(args, kwargs)
    File “/usr/local/lib/python3.8/dist-packages/kuyruk/task.py”, line 120, in send_to_queue
    with self.kuyruk.channel() as ch:
    File “/usr/lib/python3.8/contextlib.py”, line 113, in __enter__
    return next(self.gen)
    File “/usr/local/lib/python3.8/dist-packages/kuyruk/kuyruk.py”, line 58, in channel
    with self.connection() as conn:
    File “/usr/lib/python3.8/contextlib.py”, line 113, in __enter__
    return next(self.gen)
    File “/usr/local/lib/python3.8/dist-packages/kuyruk/kuyruk.py”, line 84, in connection
    conn.connect()
    File “/usr/local/lib/python3.8/dist-packages/amqp/connection.py”, line 314, in connect
    self.transport.connect()
    File “/usr/local/lib/python3.8/dist-packages/amqp/transport.py”, line 76, in connect
    self._connect(self.host, self.port, self.connect_timeout)
    File “/usr/local/lib/python3.8/dist-packages/amqp/transport.py”, line 160, in _connect
    self.sock.connect(sa)
    ConnectionRefusedError: [Errno 111] Connection refused

    Merci pour votre aide !

     

    • Ce sujet a été modifié le il y a 1 année et 2 mois par abdessamed.
    #1116
    Nathan Cheval
    Modérateur/modératrice

    Bonjour,

    Est-ce que les services (qui sont créée dans le Makefile) tournent bien ?

    • Cette réponse a été modifiée le il y a 1 année et 2 mois par Nathan Cheval.

    Lead Dev Open-Capture

    #1119
    abdessamed
    Participant

    Pour moi, il n’y a pas de souci sur l’execution du makefile. Vu que je l’ai exécuté plusieurs fois, j’ai juste une erreur lors de l’insertion de l’users.id. Dans le doute, j’ai mis en commentaire la fonction initdb.

    En pj le log du makefile.

    Attachments:
    You must be logged in to view attached files.
    #1121
    Nathan Cheval
    Modérateur/modératrice

    Vous avez installé quelle version d’OC ?

    Quand la facture ne remonte pas, merci de regarder :

    •  /opt/OpenCaptureForInvoices/bin/data/log/OCForInvoices.log
    •  systemctl status OCForInvoices-web
    • systemctl status OCForInvoices-worker

    Lead Dev Open-Capture

    #1122
    abdessamed
    Participant

    Version d’OC (branche master):

    <p class=”p1″>normal@normal:/opt/OpenCaptureForInvoices$ git describe –tags</p>
    <p class=”p2″>0.7.1</p>

    Concernant OCCForInvoices.log, il n’y a rien mis à part le test que j’ai fait hier pour insérer des fournisseurs :

    <p class=”p1″>[Open-Capture] 06-10-2020 14:32:46 INFO The following supplier was successfully added into database : Fournisseur 1</p>

    Résultat du systemctl status OCForInvoices-web:

    OCForInvoices-web.service – Gunicorn instance to Open-Capture For Invoices
    Loaded: loaded (/etc/systemd/system/OCForInvoices-web.service; enabled; vendor preset: enabled)
    Active: active (running) since Tue 2020-10-06 14:38:06 UTC; 16h ago
    Main PID: 601 (gunicorn)
    Tasks: 4 (limit: 4621)
    Memory: 389.5M
    CGroup: /system.slice/OCForInvoices-web.service
    ├─601 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi
    ├─685 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi
    ├─686 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi
    └─687 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi

    Oct 07 07:24:56 normal gunicorn[685]: return next(self.gen)
    Oct 07 07:24:56 normal gunicorn[685]: File “/usr/local/lib/python3.8/dist-packages/kuyruk/kuyruk.py”, line 84, in connection
    Oct 07 07:24:56 normal gunicorn[685]: conn.connect()
    Oct 07 07:24:56 normal gunicorn[685]: File “/usr/local/lib/python3.8/dist-packages/amqp/connection.py”, line 314, in connect
    Oct 07 07:24:56 normal gunicorn[685]: self.transport.connect()
    Oct 07 07:24:56 normal gunicorn[685]: File “/usr/local/lib/python3.8/dist-packages/amqp/transport.py”, line 76, in connect
    Oct 07 07:24:56 normal gunicorn[685]: self._connect(self.host, self.port, self.connect_timeout)
    Oct 07 07:24:56 normal gunicorn[685]: File “/usr/local/lib/python3.8/dist-packages/amqp/transport.py”, line 160, in _connect
    Oct 07 07:24:56 normal gunicorn[685]: self.sock.connect(sa)
    Oct 07 07:24:56 normal gunicorn[685]: ConnectionRefusedError: [Errno 111] Connection refused

     

     

    Pareil pour OCForInvoices-worker :
    <p class=”p1″> OCForInvoices-web.service – Gunicorn instance to Open-Capture For Invoices</p>
    <p class=”p1″>     Loaded: loaded (/etc/systemd/system/OCForInvoices-web.service; enabled; vendor preset: enabled)</p>
    <p class=”p1″>     Active: active (running) since Tue 2020-10-06 14:38:06 UTC; 16h ago</p>
    <p class=”p1″>   Main PID: 601 (gunicorn)</p>
    <p class=”p1″>      Tasks: 4 (limit: 4621)</p>
    <p class=”p1″>     Memory: 389.5M</p>
    <p class=”p1″>     CGroup: /system.slice/OCForInvoices-web.service</p>
    <p class=”p1″>             ├─601 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi</p>
    <p class=”p1″>             ├─685 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi</p>
    <p class=”p1″>             ├─686 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi</p>
    <p class=”p1″>             └─687 /usr/bin/python3 /usr/local/bin/gunicorn –timeout 300000 –workers 3 –bind unix:OCForInvoices.sock -m 007 wsgi:appwsgi</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:     return next(self.gen)</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:   File “/usr/local/lib/python3.8/dist-packages/kuyruk/kuyruk.py”, line 84, in connection</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:     conn.connect()</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:   File “/usr/local/lib/python3.8/dist-packages/amqp/connection.py”, line 314, in connect</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:     self.transport.connect()</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:   File “/usr/local/lib/python3.8/dist-packages/amqp/transport.py”, line 76, in connect</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:     self._connect(self.host, self.port, self.connect_timeout)</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:   File “/usr/local/lib/python3.8/dist-packages/amqp/transport.py”, line 160, in _connect</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]:     self.sock.connect(sa)</p>
    <p class=”p1″>Oct 07 07:24:56 normal gunicorn[685]: ConnectionRefusedError: [Errno 111] Connection refused</p>
     

     

     

    #1123
    Nathan Cheval
    Modérateur/modératrice

    Et que dis le service nginx ?

    Lead Dev Open-Capture

    #1124
    abdessamed
    Participant

    Finalement, je suis passé sur Debian, c’est beaucoup mieux. Tout a fonctionné du premier coup.
    Avec Ubuntu, ce n’est pas aussi simple à cause des dépendances qui posent problème.

     

    Merci en tout cas!

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.